Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

Engine turning - no spark & no fuel in injectors

  #1  
Old 08-04-2014, 01:04 AM
Starting Member
Thread Starter
Join Date: Apr 2009
Posts: 244
yarinzim is on a distinguished road
Default Engine turning - no spark & no fuel in injectors

Hi Guys,

As the title imply, blazer k5 90' 5.7L - the engine is turning when i try to start it, but there is no fuel coming out of the injectors and no spark in the plugs and out of the distributor (which is brand new BTW original ACDelco).

I've tested all the fuses and also tested the distributor plugs for electricity, one of them is hot, the other is not (i'm not sure if this is normal or not)

Can you please assist me in what i should check next?

Thanks in advance, Yarin.
 
  #2  
Old 08-04-2014, 06:35 AM
Starting Member
Join Date: Dec 2009
Posts: 178
Jonas is on a distinguished road
Default

had the same with my 92 350...

listen in the fuel tank if you hear the pump preassuring the system 2 or 3 seconds when the key is turned to on if it does then check the ICM. Its under the distributor. I replaced mine when i heard the pump working and after a new ICM it started right up. maybe there is a way to test the icm but it was cheap so i just replaced it...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JohnBarJB
Audio/Video Electronics
16
10-18-2015 10:48 AM
cass
Steering, Suspension & Drivetrain
10
12-16-2012 09:58 AM
tibby
2nd Gen S-series (1995-2005) Tech
0
07-11-2011 01:55 PM
New Member Area
0
09-13-2009 11:03 AM


Thread Tools
Search this Thread
Quick Reply: Engine turning - no spark & no fuel in injectors


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.