Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

Is it the starter?

  #1  
Old 06-11-2009, 08:50 PM
Thread Starter
Join Date: May 2009
Posts: 4
cnmcconnell is on a distinguished road
Question Is it the starter?

I just replaced the fuel pump and went to start the blazer.
It turned over, i used some starter fluid to get it to fire.
It would not run but you could hear the fuel pump come on and everything worked. The battery was diying and i tried to start it again and it did nothing. It wouldn't turn over, no lights, no power, nothing! Jumping it did nothing. what would be the best thing to start with. is there a fuse that could cause this, but there is 0 power anywhere.
Please help!

Thanks!
 
  #2  
Old 06-11-2009, 08:54 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,795
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

What are you driving?
 
  #3  
Old 06-12-2009, 09:38 AM
Thread Starter
Join Date: May 2009
Posts: 4
cnmcconnell is on a distinguished road
Default

it is a 93 k5 blazer
 
  #4  
Old 06-12-2009, 09:03 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,795
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

I would go through and check all of your connections and fuses just to be sure that it is not something simple.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jdmmario
Builds
0
10-25-2014 06:25 PM
an240172
2nd Gen S-series (1995-2005) Tech
5
11-18-2009 09:32 AM
Blazinmail
General Tech Help
4
03-17-2006 08:47 PM
blazergirl15
1st Gen S-series (1983-1994) Tech
3
08-28-2005 11:17 PM
blazin4eva
1st Gen S-series (1983-1994) Tech
2
02-26-2005 12:04 PM


Thread Tools
Search this Thread
Quick Reply: Is it the starter?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.