General Chat Chat about all things Blazer (and related vehicles). Off-topic stuff should be in the lounge, and all mechanical problems should be posted in the proper forum.

i think i got a short or something...

  #1  
Old 07-31-2010, 09:03 PM
97chevyblaze's Avatar
New Member
Thread Starter
Join Date: Jun 2010
Location: EH, CT
Posts: 78
97chevyblaze is on a distinguished road
Default i think i got a short or something...

today i was pulling in my driveway and my truck stalled so i started it went to put it in drive and it stalled so i put one foot on the gas and the other on the brake to get it closer to the garage then it ran fine. a couple hours later i went to go start it and nothing where the gauges are would turn on or anything, the truck will turn over but wont start the fuel pump wont go on i think theres a short or something anyone have an idea or has this ever happened?
 
  #2  
Old 07-31-2010, 10:21 PM
hemivette's Avatar
Beginning Member
Join Date: Feb 2010
Location: Marysville, Washington.
Posts: 49
hemivette is on a distinguished road
Default

I had the same problem, It's the Ignition switch. Mine was even more confusing cause I have a remote start, so it would run for 20 minutes then die. Anyway I replaced the ignition switch, and all is good. Don't pay for someone to do it, I did mine in less than an hour after reading the how to articles here in the forum. Good luck and happy motoring!
 
  #3  
Old 07-31-2010, 10:38 PM
97chevyblaze's Avatar
New Member
Thread Starter
Join Date: Jun 2010
Location: EH, CT
Posts: 78
97chevyblaze is on a distinguished road
Default

thanks man, ill try tomorrow and i do everything myself if i need help my dad will help but i got a question were you able to put your truck in neutral or anything, cause mine i cant
 
  #4  
Old 07-31-2010, 11:02 PM
hemivette's Avatar
Beginning Member
Join Date: Feb 2010
Location: Marysville, Washington.
Posts: 49
hemivette is on a distinguished road
Default

I really only drove short distances so I didn't notice it for a while,(my remote start would act as an ignition switch for 20 min.) but I would be driving, so ya it was in gear. For the first couple weeks,(until I figured it out) I would just hit my remote start button again and get another 20. LOL. But as far as it starting without the remote starter, NOT, it would just crank. The bad news is the switch is anywhere from $80-$150 depending on where you buy it. Dont cheap out, you get what you pay for!
 
  #5  
Old 07-31-2010, 11:08 PM
97chevyblaze's Avatar
New Member
Thread Starter
Join Date: Jun 2010
Location: EH, CT
Posts: 78
97chevyblaze is on a distinguished road
Default

yeah lol this blows i just picked up irocs for $60 getting ready to paint them and buy some new tires guess that will be waitin!
 
  #6  
Old 08-01-2010, 02:47 PM
97chevyblaze's Avatar
New Member
Thread Starter
Join Date: Jun 2010
Location: EH, CT
Posts: 78
97chevyblaze is on a distinguished road
Default

its all set put new ignition switch in and it runs good now. hemivette thanks for the help
 
  #7  
Old 08-02-2010, 09:22 AM
hemivette's Avatar
Beginning Member
Join Date: Feb 2010
Location: Marysville, Washington.
Posts: 49
hemivette is on a distinguished road
Default

Glad to help!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
closer
Steering, Suspension & Drivetrain
3
01-12-2012 11:09 AM
montesslvr85
Steering, Suspension & Drivetrain
7
09-08-2009 09:38 PM
XBlazer01
Paint, Body, & Interior
14
08-11-2006 11:17 PM
ivannj
2nd Gen S-series (1995-2005) Tech
7
01-18-2006 10:39 PM
blazergirl15
1st Gen S-series (1983-1994) Tech
4
07-09-2005 03:26 AM


Thread Tools
Search this Thread
Quick Reply: i think i got a short or something...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.