1994 Blazer 4.3 eng wont start <--need help - Blazer Forum - Chevy Blazer Forums

Go Back  Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help
Reload this Page >

1994 Blazer 4.3 eng wont start <--need help

General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

1994 Blazer 4.3 eng wont start <--need help

 
 
 
 
  #1  
Old 07-14-2006, 05:45 PM
Thread Starter
Join Date: Jul 2006
Posts: 4
chitowncruiser is an unknown quantity at this point
Default 1994 Blazer 4.3 eng wont start <--need help

Hello Guys and Gals.........I am a newbie to the forum so please be nice......here is my problem... my wifes truck is a 1994 blazer with the 4.3 vortec engine, automatic transmission, digital dash, a couple of days ago she came home from work and the truck ran fine when she parked it, the next day she went to start it and ....nothing...nodda...zip

1 - when u turn the key the dash flashes off and on but no crank
2 - new starter was put in yesterday but still the same thing dash flashes no crank
3 - battery is less than 6 months old
4 - when u turn the key u do hear the fuel pump engage in the rear of the truck
5 - truck will not crank in Neutral either
6 - relay on firewall on drivers side in engine compartment (outer one next to fender) clicks when u turn the key
7 - truck has over 165.000 miles and is still a runner when it runs
8 - all fuses have been looked at and checked out ok

I'm not a mechanic not do i wish to take it to one if i can fix it myself with your help here, could it be the relay that is bad??? or is it the neutral saftey switch or the ignition switch on the column???......sorry for such a long post.
 
  #2  
Old 07-14-2006, 07:44 PM
Join Date: Jul 2006
Posts: 4
Lowtruck94 is an unknown quantity at this point
Default RE: 1994 Blazer 4.3 eng wont start <--need help

Ok, well to see if I can give you any suggestions on this one, I used to be a mechanic myself,, ok more than common problems with the cables being corroded at the connections to the battery, ok, also take into effect that you could also have bad grounds, not just the power cable, so I would check off first the connections, then if you have a volt meter check the voltage down at the end of the starter/ humm think that if that was replaced too then you might also want to check to see if the bolt is tight as long as you got you 12V at the starter. then it become a different ballgame of ignition switch, or possibility of short in wire from ignition switch to starter. well good luck I hop this helps

Enjoy

[email protected]
DJSPARKS
http://www.myspace.com/lowtruck94
 
  #3  
Old 07-15-2006, 04:15 PM
BF Veteran
Join Date: Jun 2006
Location: Vancouver. B.C. Canada
Posts: 3,429
Chevy Lover is a jewel in the roughChevy Lover is a jewel in the roughChevy Lover is a jewel in the rough
Default RE: 1994 Blazer 4.3 eng wont start <--need help

Welcome to the site. Don't apologize for a long post that's full of useful information, you're just making it easier for us to help.

First thing that comes to mind is a possible ignition switch. If you have a test light or a voltmeter and a helper, here's what I suggest.
With the parking brake on (for safety) see if you can get to the wiring on the starter motor. There is a small wire attatched to the "S" terminal. attatch your voltmeter or test light to a good ground (like a starter mounting bolt) and to the "S" terminal. Have your helper turn the key to "crank". The test light should light (or voltmeter show 12 volts).
If you have voltage to the "s" terminal, a tight connection and 12 volts to the (big) battery terminal and the starter motor mounting bolts are tight, then the starter is no good.
If you don't get voltage to the "S" terminal, then the problem is either in the ignition switch on the steering column or the ignition lock cylinder or the wiring between the switch and the starter.
Hope this info gets you started. Keep us posted.
 
  #4  
Old 07-16-2006, 02:30 AM
Thread Starter
Join Date: Jul 2006
Posts: 4
chitowncruiser is an unknown quantity at this point
Default RE: 1994 Blazer 4.3 eng wont start <--need help

hey guys thanks for all of ur answers so far..........put a new battery in it today and tried it and still nothing......the starter is brand new and was replaced just a few days ago, im getting power to the starter ( tried to jump start it with the ignition key in the on position ) but it still woudnt turn over.....sounds more like the ignition switch to me.......how much of a hassle is it to relace it ???? as i did one in a 1989 Firebird Formula once before....let me know and thanks again guys.......
 
  #5  
Old 07-16-2006, 07:45 AM
BF Veteran
Join Date: Jun 2006
Location: Vancouver. B.C. Canada
Posts: 3,429
Chevy Lover is a jewel in the roughChevy Lover is a jewel in the roughChevy Lover is a jewel in the rough
Default RE: 1994 Blazer 4.3 eng wont start <--need help


ORIGINAL: chitowncruiser

hey guys thanks for all of ur answers so far..........put a new battery in it today and tried it and still nothing......the starter is brand new and was replaced just a few days ago, im getting power to the starter ( tried to jump start it with the ignition key in the on position ) but it still woudnt turn over.....sounds more like the ignition switch to me.......how much of a hassle is it to relace it ???? as i did one in a 1989 Firebird Formula once before....let me know and thanks again guys.......
you say you're getting power to the starter. To the small "S" terminal (possibly a purple wire)? Or power to the big wire that goes to the battery. If you get power to the small wire it should engage the starter.
T
I don't have a manual for your year, but the ignition switch is probably mounted on the lower steering column.
A rod goes from the key cylinder down to activate the ignition switch. Probablly two 8mm bolts holding it in place.
Sorry if this is vague, as I said, I don't have a manual.
 
  #6  
Old 07-16-2006, 02:38 PM
Thread Starter
Join Date: Jul 2006
Posts: 4
chitowncruiser is an unknown quantity at this point
Default RE: 1994 Blazer 4.3 eng wont start <--need help

Chevy Lover

since I have already put in a new

1 - starter
2 - battery

I'm going to assume it is the ( switch ) that is bad since when u turn the key the digital dash flashes off and then back on but with no crank......upon checking for parts i have found 2 things

1 - ignition switch - which is located under the steering column
2 - ignition cylinder - where the key goes in to start it

so i am going to drop the column and replace the switch and see if that does the trick.......i'll post back when i'm done and let u know if that fixed it........thanks
 
  #7  
Old 08-06-2006, 03:21 PM
Thread Starter
Join Date: Jul 2006
Posts: 4
chitowncruiser is an unknown quantity at this point
Default RE: 1994 Blazer 4.3 eng wont start <--need help

ok guys

put in a new ignition switch and still nothing..turn the key and the digital dash still flashes off and then back on..im getting power to everything like lights /radio/ blower motor..what else can be wrong with it?

it just wont crank which i dont understand.....could it be the ignition cylinder?....but i dont have a chip in the key im drawingblanks here can u guys help put
 
  #8  
Old 08-06-2006, 03:32 PM
BF Veteran
Join Date: Jan 2006
Location: Hampstead Maryland
Posts: 2,612
XBlazer01 has a spectacular aura aboutXBlazer01 has a spectacular aura about
Default RE: 1994 Blazer 4.3 eng wont start <--need help

hmmmmm

I may be totaly off but this kidna sounds like what was happening to my friends 300ZX.

If not ignore me and im dumb lol. pull out the headunit and dash and look around for a lose wire. Cause his wouldnt start and we found some power wire (i forgot which one its been awhile) Look for an exposed or broken wire. If you already did this as i said im dumb and im sorry lol
 
  #9  
Old 11-28-2009, 01:47 PM
Beginning Member
Join Date: Nov 2009
Posts: 10
bornla is on a distinguished road
Default

it's your "lock cylinder,believe me....big problem, little price to buy(16.00)
 
  #10  
Old 11-28-2009, 08:03 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,756
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

Holy crap. I know you have been digging up any and all threads that you "think" that your comments could help, but please man, stop the insanity... You offer up NO explanation at all and then you go dig up a thread like this one that is over 3 years old... STOP IT already!
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kerrhbk
1st Gen S-series (1983-1994) Tech
14
01-17-2012 03:53 PM
toydoc
Lighting & Electrical
1
04-28-2011 08:16 PM
Starter Guy
Engine & Transmission
1
12-13-2009 08:30 AM
rick nielsen
Engine & Internal
1
10-14-2007 03:41 AM
arbowman
2nd Gen S-series (1995-2005) Tech
14
07-09-2007 07:11 AM


Thread Tools
Search this Thread
Quick Reply: 1994 Blazer 4.3 eng wont start <--need help


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.