General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

New to forum, need help with 95' Blazer

 
 
 
 
  #1  
Old 08-13-2006, 10:32 PM
Thread Starter
Join Date: Aug 2006
Posts: 1
ZeroHour is an unknown quantity at this point
Default New to forum, need help with 95' Blazer

Hey all, I'm a normal member over on contour.org, and blazer's aren't my speciality. Unfortunately my mom has one and its running with quite a bit of problems.

Right now the large issue is that the trans overheats and will overflow the transmission pour spout. I has several CELs which are 134,135,141,340,1406. The first three are all O2 related problems and probably because of the cat being removed.

But the 340 is cam position sensor which is a cause of concern. But my major issue is the 1406. It is suppose to be differential pressure feedback sensor fault. Being a Ford owner I know some about the DPFE sensors. I'm not sure where it is on the blazer even after digging around the engine bay. The v6 crammed into the blazer is like my Contour. Alot of wires and motor in a small place. lol

So can any all knowing chevy masters point this ford boy in the right direction? I would really like to get the blazer back up and running properly. TIA!
 
  #2  
Old 08-13-2006, 10:44 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,789
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: New to forum, need help with 95' Blazer

Ok to break down your codes for you:
P0134 - O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 1) -
P0135 - O2 Sensor Heater Circuit (Bank 1 Sensor 1) - System Grouping: Fuel And Air Metering
P0141 - O2 Sensor Heater Circuit (Bank 1 Sensor 2) - System Grouping: Fuel And Air Metering
P0340 - Camshaft Position Sensor A Circuit (Bank 1 or Single Sensor) - System Grouping: Ignition System Misfire
P1406 - Exhaust Gas Recirculation (EGR) Position Sensor Performance - System Grouping: Manufacturer Specific

So, I find it highly unlikely that all of this is having a problem all at the same point. I am actually thinking that it may be related to a poor ground to either the PCM or the individual sensors. I know there is a grounding location on the firewall, as well as one off the back of each head. Without looking at the wiring diagrams for your mom's '95, I cannot determine if all of these sensors utilize the same grounds.

Also, the heater circuit codes would not be a result of a missing catalytic converter. B1S1 is the main O2 sensor for the fuel injection system and is required for the proper operation of the vehicle. B1S2 is for catalyst monitoring only, but cannot be simply removed. A simulator must be added if the cat is missing unless you get the codes programmed out of the PCM.

So yeah, check the grounds and let us know.
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DEATH-TRAP
2nd Gen S-series (1995-2005) Tech
3
02-22-2012 07:01 AM
nickgriffin1
2nd Gen S-series (1995-2005) Tech
4
11-20-2011 12:51 PM
babeba67
2nd Gen S-series (1995-2005) Tech
4
03-22-2011 06:07 AM
hdelgad1
1st Gen S-series (1983-1994) Tech
2
11-19-2008 07:00 AM


Thread Tools
Search this Thread
Quick Reply: New to forum, need help with 95' Blazer


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.