Defroster issue - Blazer Forum - Chevy Blazer Forums


Lighting & Electrical Post your lighting and chassis/engine electrical questions here. Any audio/video questions should be posted in the 'Audio/Video Electronics' section.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-09-2017, 02:09 PM
Bagherra's Avatar
Starting Member
Thread Starter
 
Join Date: Sep 2014
Location: Va Beach, VA
Posts: 212
Bagherra is on a distinguished road
Default Defroster issue

Noticed today while driving the metal clip from my defroster was hanging there.


Can I just superglue it back to the window and have to issues?


TIA
Reply With Quote
  #2  
Old 01-09-2017, 02:23 PM
richphotos's Avatar
Moderator
 
Join Date: Dec 2011
Location: Minneapolis, MN
Posts: 4,795
richphotos is a jewel in the roughrichphotos is a jewel in the roughrichphotos is a jewel in the rough
Default

Nope, it needs to make a connection to the heating elements. At most automotive parts stores they sell a glue which current can pass through just for your issue.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mystery wire and rear defroster FlatTopFoley Audio/Video Electronics 3 02-10-2009 08:21 AM
Rear Defroster Jerry60k 1st Gen S-series (1983-1994) Tech 5 12-20-2008 05:23 PM
defroster cr8390 2nd Gen S-series (1995-2005) Tech 8 08-19-2008 02:31 PM
defroster setting causing stalling dlew133 GMT 360/370 Tech 4 04-04-2008 09:09 PM
rear defroster okmomw/blazer General Tech Help 4 06-06-2006 09:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:31 PM.