Need Help! A/C clutch not engaging - Blazer Forum - Chevy Blazer Forums


Lighting & Electrical Post your lighting and chassis/engine electrical questions here. Any audio/video questions should be posted in the 'Audio/Video Electronics' section.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-13-2017, 12:44 PM
DARK1's Avatar
Starting Member
Thread Starter

 
Join Date: Jan 2017
Location: South FL
Posts: 138
DARK1 is on a distinguished road
Default Need Help! A/C clutch not engaging

The wiring in the 95/96 S-10s is a bit different at many places than years before it or after it. I have collected a dozen diagrams - most of which let me down with mis-information on *my* truck before.

Guys that have had wiring issues with the 95/96 understand the problems that can arise from not using the correct diagram. My "Quad Mod" was tricky because of the unique wiring for the Headlights and the right diagram made the mod quick & simple. Thanx swartikk!

I hope maybe I can ask for help again. The A/C was Ice cold before I started disassembling the face of my dash panel. While I am no closer to creating a "Dome Override" for this unusually wired beast; now the A/C clutch doesn't engage. I am hoping I just blew a fuse or a relay but this year doesn't have a cluster of "monster fuses" under the hood. A buddy of mine knicked a wire to the compressor and jumped it. The A/C clutch engaged and was blowin' cold instantly. My goal is to restore service from the climate control panel.

Any advice is appreciated.

Last edited by DARK1; 07-13-2017 at 08:34 PM. Reason: grammer correction
Reply With Quote
  #2  
Old 07-14-2017, 08:23 PM
Starting Member

 
Join Date: Mar 2014
Posts: 226
hoebob69 is on a distinguished road
Default

Quote:
Originally Posted by DARK1 View Post
The wiring in the 95/96 S-10s is a bit different at many places than years before it or after it. I have collected a dozen diagrams - most of which let me down with mis-information on *my* truck before.

Guys that have had wiring issues with the 95/96 understand the problems that can arise from not using the correct diagram. My "Quad Mod" was tricky because of the unique wiring for the Headlights and the right diagram made the mod quick & simple. Thanx swartikk!

I hope maybe I can ask for help again. The A/C was Ice cold before I started disassembling the face of my dash panel. While I am no closer to creating a "Dome Override" for this unusually wired beast; now the A/C clutch doesn't engage. I am hoping I just blew a fuse or a relay but this year doesn't have a cluster of "monster fuses" under the hood. A buddy of mine knicked a wire to the compressor and jumped it. The A/C clutch engaged and was blowin' cold instantly. My goal is to restore service from the climate control panel.

Any advice is appreciated.
I just fixed the same problem on mine. Locate the ground wire going into the relay,and splice another ground wire into it. I ran mine from the firewall. Even with strange wiring the wire color is the same on the ac components. The ground wire is the issue.
Reply With Quote
  #3  
Old 07-16-2017, 07:42 PM
DARK1's Avatar
Starting Member
Thread Starter

 
Join Date: Jan 2017
Location: South FL
Posts: 138
DARK1 is on a distinguished road
Default

Thanx Hoebob

I spent the afternoon at my local yard on Friday looking through 75-100 blazers for the same relay configuration. Every one of them looked similar to each other (wiring) but no relays. Until I found it! The bracket of 3 was screwed on the back firewall - just like mine! The VIN Sticker on the rear said 1996 Blazer. After I typed this thread I took a moment to digest what I wrote. At the risk of everyone thinking I was a whining idiot; I decided to post anyway. If I was gonna ask for precise help - I have to take a risk that the very specific post would not scare them off. After all. Even if 50 guys offered their help, it would be useless if they did not base advice on a 95/96. When I get this done I think I'm gonna post a pict of the set of relays hanging on the firewall. I don't think any one will believe it until they see it LOL

In the meanwhile .... My plan was to simply swap the relay (I think it is the one closest to the passenger door). If that plan fails I will fall back on tapping on a new ground wire. Can you tell me what color it is at the relay?

Last edited by DARK1; 07-16-2017 at 07:44 PM.
Reply With Quote
  #4  
Old 07-17-2017, 10:25 PM
DARK1's Avatar
Starting Member
Thread Starter

 
Join Date: Jan 2017
Location: South FL
Posts: 138
DARK1 is on a distinguished road
Default

I got an entire cluster of relays at the yard. I looked at the two wires going into the compressor for color. The one my guy knicked was a solid green. That is what I based the question of "which one izit" on. All had the same item # on top.
I swapped one. No change.
The second one I swapped while engine was running. No change again
Finally I grounded the green wire from the relay wire entry while running. No change.
Finally I grounded the green wire from the A/C knick while running. No change.

Things are not going well. I may not have made good contacts. I may have blown something while letting the engine run.

I could go on all night about the maybes. Gonna sleep onit and hit it again on Wednesday. I am attaching an image of the relay cluster unique to the 95/96s
Attached Thumbnails
Need Help! A/C clutch not engaging-relays96s-10-small.jpg  
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AC clutch not engaging, need more help ferret13sj 2nd Gen S-series (1995-2005) Tech 2 07-03-2017 10:41 AM
4x4 engaging, but not fully engaging? seriosbrad 2nd Gen S-series (1995-2005) Tech 6 11-07-2015 09:08 PM
A/C clutch not engaging ExpressEN1 2nd Gen S-series (1995-2005) Tech 7 10-16-2011 06:04 PM
95 Blazer A/C Clutch not engaging gscrippler 2nd Gen S-series (1995-2005) Tech 2 03-14-2011 06:37 PM
clutch problems (clutch goes to the foor) Red03 Engine & Transmission 2 09-25-2008 08:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:38 AM.