Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2010, 05:46 PM
Beginning Member
 
Join Date: Mar 2008
Location:
Posts: 27
bigt7088 is an unknown quantity at this point
Default 2000 Blazer Security System?

I tried searching for this, but didn't have much luck. I have a 2000 Blazer 4x4 4 door that won't start. It was fine before (other than replacing the intake gasket last month). Everything works fine, but it acts like it has no battery power when turning the key on. I had this problem before when I had new tires put on, and the guy at the shop told me it was a security issue and that holding the turn signal to the right will deactivate it when starting... and it seemed to work, but not now. Does anybody have any tips or links that might help? Thanks!
  #2  
Old 05-03-2010, 06:10 PM
Benedict1337's Avatar
BF Veteran
2000 Chevrolet Blazer
 
Join Date: Aug 2009
Location: Harrisburg PA
Posts: 3,137
Benedict1337 will become famous soon enough
Default

does your interior light still light up when you open the doors? can you turn your headlights on? I know I had a problem similar to what you had. I had to tighten my battery terminals and it started right up. I would check that first.
__________________
Build Thread Flickr

2010 ROTY
Quote:
Originally Posted by oktain View Post
Story: you sliipped in someone's floor lunch while you were carrying a keg and when you landed on your *** you got the keg in the face, because of your chisseled chin you split the keg open and half of it ended up funneling down your throat on it's own.
  #3  
Old 05-03-2010, 09:34 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 39,970
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default

The turn signal is in no way connected to the passlock system in the truck. It is possible that the ignition switch is not making the proper connection to engage the starter. The ignition switches in these trucks are known to have issues.

Does your security light come on and stay on while you are trying to start the truck?
  #4  
Old 05-04-2010, 01:14 AM
Beginning Member
 
Join Date: Mar 2008
Location:
Posts: 27
bigt7088 is an unknown quantity at this point
Default

No, the security light doesn't stay on. And yes, everything else electric works fine. I'll be away from the truck until Friday, but I can have someone check the ignition switch contacts. Thanks, I really appreciate the help!
__________________
I like money.
  #5  
Old 05-04-2010, 10:58 AM
New Member
 
Join Date: Apr 2010
Location: upstate ny
Posts: 98
kennybopaloo is on a distinguished road
Default security

on mine the security light shows in the middle of the dash when i open the door and the red light keeps blinking by the radio.

what does this mean.

if it has a security system why don't i have a special key for that ?????
__________________
2002 4wd 4 door chevy blazer white 4.3 87,000 miles
  #6  
Old 05-04-2010, 10:18 PM
Beginning Member
 
Join Date: Mar 2008
Location:
Posts: 27
bigt7088 is an unknown quantity at this point
Default

One thing I should note is that I did have a service engine light after doing the intake gasket and distributor rotor and cap, which was the misfire error on #6 that was fixed after getting a new pulg wire. The light is on now, but I'm sure that's normal when the key is on but it's not running.

While I'm away, my father decided on taking it to a local shop who helped us get the distributor timing right last time. I guess they're thinking starter, so they'll check it out too. I'll update when I hear something.
__________________
I like money.
  #7  
Old 05-08-2010, 12:37 PM
Beginning Member
 
Join Date: Mar 2008
Location:
Posts: 27
bigt7088 is an unknown quantity at this point
Default

Just went by the shop and so far he has checked the starter/connections, changed the ignition switch and changed the neutral transmission safety switch... all with no results. I guess we'll have to bite the dust and take it to the stealership. Any suggestions before I do so?
__________________
I like money.
  #8  
Old 05-10-2010, 12:34 AM
WolfPack's Avatar
BF Veteran
2000 Chevrolet Blazer
 
Join Date: Oct 2007
Location: Raleigh, NC
Posts: 3,747
WolfPack is a jewel in the roughWolfPack is a jewel in the roughWolfPack is a jewel in the rough
Send a message via AIM to WolfPack
Default

Check your grounds. There is one on the firewall near the distributor, towards the pass side a bit, also one on the top of the frame near the back of the drivers side front wheel well. Also the ground on the starter is worth checking. I think there is also a ground connection on the engine block, passenger side, near the oil pan (trying to remember from my body lift).

Did you do any voltage testing at the starter? At the ignition switch?


Electrical problems suck.


Edit: Is the starter engaging at all? Or there is no sound at all when you turn the key?
__________________
2000 Blazer 4d LS 4x4 - 265/70/15 General Grabber AT2s


SOLD - 2011. She will be missed.
  #9  
Old 12-13-2010, 07:29 PM
New Member
 
Join Date: Oct 2010
Posts: 3
fastback66 is on a distinguished road
Default

Not sure what the solutions are to these posts but... I have a 2000 blazer 2wd and my "security" light on the dash comes on while driving. I've consulted the owner's manual, shop manual, internet, dealer, etc. but no one knows why it does it. Anyone out there have the same problem? If it's on when I stop and turn off the engine I have to wait several minutes to restart.
Old 12-13-2010, 07:29 PM
 
 
 
Closed Thread

Tags
2000, 99, blazer, chevy, flashing, light, loc, off, problem, problems, radio, security, srart, start, system, turned


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 03:32 PM.

Internet Brands, Inc.