Engine & Internal Chat about beefing up your Blazer's engine insides here.

new fuel pump already bad?

  #1  
Old 08-21-2011, 02:34 PM
wornknobby3's Avatar
Beginning Member
Thread Starter
Join Date: Apr 2011
Location: New Hampshire
Posts: 25
wornknobby3 is on a distinguished road
Default new fuel pump already bad?

ok so i have a 89 K% with a 350, and i replaced the mechanical fuel pump after getting my new 355 installed, problem is, gas leaks really bad as i rev up the engine, now i did some research and most people are saying that the diaphragm is bad when this happens and the gas comes out of the two vent holes on the pump, well i tried putting on yet another brand new pump, and a new line just to make sure my flare on the 3/8 line was good and it STILL leaked once again... any suggestions? this shouldn't be rocket science but for some reason i cant get it to stop
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BouncingRadical
2nd Gen S-series (1995-2005) Tech
14
11-27-2015 12:30 AM
Duram98jimmy4x4
New Member Area
11
09-25-2009 04:08 PM
bowtie lifer
New Member Area
6
08-10-2009 05:29 AM
GotYoNacho
2nd Gen S-series (1995-2005) Tech
6
02-24-2009 07:41 PM
Mapoftazifosho
2nd Gen S-series (1995-2005) Tech
5
01-08-2007 03:35 PM


Thread Tools
Search this Thread
Quick Reply: new fuel pump already bad?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.