Oil Pressure Drop - Blazer Forum - Chevy Blazer Forums

Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

Oil Pressure Drop

  #1  
Old 01-13-2019, 06:56 PM
Phantom309's Avatar
New Member
Thread Starter
Join Date: Jan 2019
Location: Usa
Posts: 4
Phantom309 is on a distinguished road
Default Oil Pressure Drop

Howdy y'all. I'm new here and simply was curious if any of y'all have had your oil pressure guage stay above 40 when you first state up, but when it gets to Temp it drops. Not completely losing pressure, but it sticks around 20 mark. If any of y'all can help ifI appreciate it.
 
  #2  
Old 01-13-2019, 07:16 PM
blazen_red_4x4's Avatar
Super Member
Join Date: Apr 2014
Location: Lake City, Florida
Posts: 1,286
blazen_red_4x4 is on a distinguished road
Default

Sounds normal actually, mine does about the same.

Once warm, it should raise with the RPM's as well.
 
  #3  
Old 01-13-2019, 07:33 PM
Phantom309's Avatar
New Member
Thread Starter
Join Date: Jan 2019
Location: Usa
Posts: 4
Phantom309 is on a distinguished road
Default

Originally Posted by blazen_red_4x4 View Post
Sounds normal actually, mine does about the same.

Once warm, it should raise with the RPM's as well.
The issue is that mine only remains at 20lbs ish until the motor is cold started
 
  #4  
Old 01-13-2019, 07:59 PM
christine_208's Avatar
Super Member
Join Date: Dec 2016
Location: Moscow, ID
Posts: 1,855
christine_208 is on a distinguished road
Default

Welcome. The pressure can be pretty low when the engine is warm and only idling.
 
  #5  
Old 01-14-2019, 07:43 PM
Junior Member
Join Date: Nov 2018
Location: Grayson KY
Posts: 332
go chevy is on a distinguished road
Default

I also agree with Christine and Blazen Red, they know their stuff! Mine is about just the same pressure...
 
  #6  
Old 01-14-2019, 07:46 PM
Junior Member
Join Date: Nov 2018
Location: Grayson KY
Posts: 332
go chevy is on a distinguished road
Default

Forgot too say welcome aboard! Phantom 309... Love the name and that was a great song
 
  #7  
Old 01-14-2019, 09:37 PM
odat's Avatar
Senior Member
Join Date: Sep 2013
Location: wyoming
Posts: 776
odat is on a distinguished road
Default

Originally Posted by Phantom309 View Post
The issue is that mine only remains at 20lbs ish until the motor is cold started
If you have no rise in pressure as you increase RPMS your oil pressure sending unit may be getting weak,
However as blazen_red stated there is no problem with 20 lbs for pressure. It will run all day with that.
Heck in the old days when your inst. cluster just had idiot lights the oil light usually didn't flicker until pressure hit 2 or 3 lbs
Yes I'm that old
 

Last edited by odat; 01-19-2019 at 08:52 PM.
  #8  
Old 01-19-2019, 08:05 PM
TxTurtle's Avatar
New Member
Join Date: Jan 2016
Location: DFW
Posts: 71
TxTurtle is on a distinguished road
Default

Mine did the same thing. I stressed out about it for a while after getting the balzer & then realized it was pretty much the same everytime & decided it was within operating parameters. Sending unit might be on it's way out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
racsan
Engine & Transmission
11
03-07-2014 10:14 PM
2dr jimmy guy
Engine & Transmission
2
01-26-2013 09:36 PM
maddogggrrr
Engine & Transmission
1
06-25-2012 07:52 PM
88s10Blazer
1st Gen S-series (1983-1994) Tech
2
12-06-2006 02:49 PM


Thread Tools
Search this Thread
Quick Reply: Oil Pressure Drop


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.