Oil Pressure Issue - Blazer Forum - Chevy Blazer Forums

Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

Oil Pressure Issue

  #1  
Old 01-03-2019, 03:21 PM
Starting Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Blaziergirl is on a distinguished road
Default Oil Pressure Issue

Hello all,

My blazer has an oil pressure issue. The oil pressure stays at 20-30 while driving but when stopped and at low idle goes down to 0 . When high idle when motor is forst started the guarge is around 50. Any thoughts?
 
  #2  
Old 01-04-2019, 01:16 AM
christine_208's Avatar
Super Member
Join Date: Dec 2016
Location: Moscow, ID
Posts: 1,656
christine_208 is on a distinguished road
Default

Are you using the correct oil viscosity? When did you first notice this? Did it come on gradually or all at once?

I hate throwing parts at problems but in this case, perhaps the oil pressure sender has gone bad. They are not very expensive so it might be worth replacing it with a new one.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
LWegner
Engine & Transmission
1
05-08-2011 09:25 AM
Spectreblazer
Full Size K5 Tech
3
03-16-2010 12:16 AM
davidsv8mustang
2nd Gen S-series (1995-2005) Tech
1
02-18-2010 03:29 PM
zippy199
Engine & Transmission
4
10-22-2009 07:36 PM
Ak95Blazer
2nd Gen S-series (1995-2005) Tech
5
01-07-2009 07:56 AM


Thread Tools
Search this Thread
Quick Reply: Oil Pressure Issue


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.