Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

1984 Blazer 4WD clicking

  #1  
Old 01-18-2011, 09:44 AM
New Member
Thread Starter
Join Date: Jan 2011
Posts: 2
cptjeff24 is on a distinguished road
Default 1984 Blazer 4WD clicking

I have a 1984 Blazer with auto hubs. 4WD works fine in high and low. But when I put the truck back in 2W i usually end up hearing a clicking sound from the drivers side front tire. On occasion I'll get a few loud clunks. If I throw the truck back into 4W the sounds go away. I know that these factory auto hubs are considered junk by most and I figure that the driver hub is simply not disengaging. Possibly a bad return spring?

Thanks!
 
  #2  
Old 01-18-2011, 05:39 PM
abig84's Avatar
BF Veteran
Join Date: Aug 2009
Location: munster indiana
Posts: 3,426
abig84 will become famous soon enoughabig84 will become famous soon enough
Default

probably something with the hubs as you said. i hate those things and were always the first thing to be thrown away when i bought a new blazer. try maybe backing up 2 feet after going back to 2wd on some of the manual hubs after they get mud and junk in there the return springs dont pull as good as they used to and you have to take the tension off the drivetrain to get it back into 2wd
 
  #3  
Old 01-18-2011, 06:39 PM
Mighty Mouse's Avatar
New Member
Join Date: Dec 2010
Location: Carlisle, Pa
Posts: 51
Mighty Mouse is on a distinguished road
Default

Like mentioned above, it sounds like a hub problem. My F250 has auto hubs and I have to back up about 15 feet with them.
 
  #4  
Old 01-19-2011, 06:38 AM
New Member
Thread Starter
Join Date: Jan 2011
Posts: 2
cptjeff24 is on a distinguished road
Default

Thanks for the input. abig84, I have been backing up but to no avail. I take it you switched to manual lock out thens? It's not tough is it?

Thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tahwos
Steering, Suspension & Drivetrain
7
04-21-2014 02:59 PM
Blazinflaboy
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
5
06-22-2010 09:03 PM
cmh_20
1st Gen S-series (1983-1994) Tech
0
11-21-2009 11:39 AM
onecrazyfoo4u
Engine & Transmission
14
12-17-2008 11:20 AM
normzo
Paint, Body, & Interior
1
03-09-2008 11:32 PM


Thread Tools
Search this Thread
Quick Reply: 1984 Blazer 4WD clicking


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.