Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

87 K5 Blazer trouble :'(

  #1  
Old 01-29-2010, 02:52 PM
New Member
Thread Starter
Join Date: Jan 2010
Posts: 5
87ChevyBlazer is on a distinguished road
Default 87 K5 Blazer trouble :'(

i just bought a 87 k5 blazer and have been replacing alot just to figure out the problem. what its doing and right after idle it would act like its getting too much fuel or not enough and act like its going to die but wont. im getting a code 44 (lean exhaust) but if anything its running rich. and ideas? thank you


Spencer J. Linz
 
  #2  
Old 01-29-2010, 03:10 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,803
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

An exhaust leak ahead of the O2 sensor in the exhaust pipe can cause a false lean reading. That would be the first thing I would check for.
 
  #3  
Old 01-29-2010, 08:00 PM
New Member
Thread Starter
Join Date: Jan 2010
Posts: 5
87ChevyBlazer is on a distinguished road
Default

yes possible but the whole dieing problem affects your driving since its right after idle it would jolt back and forth when you try to idle at a speed anywhere between 0 and 50
 
  #4  
Old 03-28-2010, 02:56 PM
New Member
Thread Starter
Join Date: Jan 2010
Posts: 5
87ChevyBlazer is on a distinguished road
Default Fixed :D

after replacing the ecm i happened to catch the problem out the corner of my eye while under the hood... for some reason the chug problem was happening when the egr valve opened so as it was chugging i pulled the vacuum line to the egr valve it closed and the chugging stopped so in case i plugged up the vacuum lines to the egr and got rid of the smog pump waste for me here and problem solved.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fivemillerz
General Tech Help
5
07-17-2006 08:26 PM
dcjones
2nd Gen S-series (1995-2005) Tech
6
01-19-2006 10:54 PM
danimalvt
Engine & Internal
4
12-20-2005 08:32 PM
luvfroses
1st Gen S-series (1983-1994) Tech
1
07-07-2005 11:44 PM
sully
2nd Gen S-series (1995-2005) Tech
6
06-08-2005 08:06 AM


Thread Tools
Search this Thread
Quick Reply: 87 K5 Blazer trouble :'(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.