Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

93 K1500 code 12

  #1  
Old 04-21-2010, 06:31 PM
Beginning Member
Thread Starter
Join Date: May 2009
Location: Atacama, Chile
Posts: 35
mikeknuckey is on a distinguished road
Default 93 K1500 code 12

Hi friends, Im still havin' problems with my Blazer...
Transsmision didnt make any shift (yet), ABS ligth its on same for service engine soon...

I made the paper clip "test", and it flashes code 12... but I cant find what it means! every code list I've found starts in 13...

Please heeelp me!!! Its have been so sad to see my red Blazer sleeping out of my house for 3 months.

Thanks!
 
  #2  
Old 04-21-2010, 07:30 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,802
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

12 = system normal.
 
  #3  
Old 04-22-2010, 10:30 AM
Beginning Member
Thread Starter
Join Date: May 2009
Location: Atacama, Chile
Posts: 35
mikeknuckey is on a distinguished road
Default

Originally Posted by swartlkk View Post
12 = system normal.
Naaaa... So now Im very confused... Couse ligths at panel are still on (abs & service), and tranny dont make any shift (on any gear), but have a lot of power when I press the pedal.

Dont know what can be wrong, speed sensor??? (spedometer works).

Another strange thing its when I turn it on, RPMs climb up to 2000 and a seconds later goes to 1200, I change the oxigen sensor, but theres nothing diferent.

Any help will be priceless
 
  #4  
Old 04-22-2010, 01:53 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,802
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

Does the truck move and just not shift? If so, does it feel like it is stuck in 1st gear?
 
  #5  
Old 04-22-2010, 02:17 PM
Beginning Member
Thread Starter
Join Date: May 2009
Location: Atacama, Chile
Posts: 35
mikeknuckey is on a distinguished road
Default

Originally Posted by swartlkk View Post
Does the truck move and just not shift? If so, does it feel like it is stuck in 1st gear?
Thats right, its move and when it get 3500rpm I decrease the pressure of the pedal and it makes something as a shift (revs fall to 2000), but when you get 3000 again its only revs and no power till you get the 4500, and produce traction again.
But if I only press the pedal (like it should be) it goes to red zone without shifting.
 
  #6  
Old 04-22-2010, 02:28 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,802
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

It sounds like you have an internal problem with the transmission.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
evlblkwpnz
Steering, Suspension & Drivetrain
2
12-18-2009 08:26 AM
nash_686
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
6
11-25-2009 06:43 AM
Blaze GM4
Sights N Sounds
11
02-18-2008 06:56 PM
izaquad
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
3
11-26-2007 08:19 PM
aaronfisher
General Tech Help
1
10-01-2006 10:18 PM


Thread Tools
Search this Thread
Quick Reply: 93 K1500 code 12


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.