Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

fuel not getting to throttle body

  #1  
Old 10-09-2016, 07:48 PM
New Member
Thread Starter
Join Date: Oct 2016
Posts: 3
nomad5059 is on a distinguished road
Unhappy fuel not getting to throttle body

I have an 89 with the 350TBI engine. It will not start, no fuel. I have already changed the relay and fuse, but still not getting fuel. When i turn on key, i cannot hear the pump running. Is there any other electrical type things i can check before i pull the tank to replace the pump?

thanks
 
  #2  
Old 10-10-2016, 12:22 PM
abig84's Avatar
BF Veteran
Join Date: Aug 2009
Location: munster indiana
Posts: 3,426
abig84 will become famous soon enoughabig84 will become famous soon enough
Default

one of the ghetto ways of checking the fuel pump is lay under the truck and hit the tank with a big rubber mallet as someone cranks the engine. we do that all the time at work so we dont have to push the fuel pump job into the shop
 
  #3  
Old 10-16-2016, 08:38 PM
New Member
Thread Starter
Join Date: Oct 2016
Posts: 3
nomad5059 is on a distinguished road
Default

ok, i have replaced the pump, fuse, and relay. I am not getting power to fuse, still not starting. when i turn key on to check for codes, i am getting no lights in dash area. I am thinking it might be the ignition switch. Any advice would help a great deal, it is now hunting season here and this is the only rig i have to hunt with.
 
  #4  
Old 10-17-2016, 01:24 PM
abig84's Avatar
BF Veteran
Join Date: Aug 2009
Location: munster indiana
Posts: 3,426
abig84 will become famous soon enoughabig84 will become famous soon enough
Default

i would also guess ignition switch. figure out what wire is sending power to the switch and make sure it has 12v then check the output wire to see if that energizes after turning the key forward
 
  #5  
Old 10-21-2016, 06:34 PM
New Member
Thread Starter
Join Date: Oct 2016
Posts: 3
nomad5059 is on a distinguished road
Default

changed ignition switch with no change. still no power getting to pump relay. about out of ideas. is it possible the brain box is fried?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
blazerowner2011
2nd Gen S-series (1995-2005) Tech
6
08-02-2011 07:52 AM
johnb
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
1
07-10-2011 10:13 AM
LO3671
1st Gen S-series (1983-1994) Tech
4
04-03-2010 03:53 AM
Taz
Engine & Transmission
2
10-17-2009 12:21 PM
roaster
Engine & Transmission
8
02-19-2008 10:36 PM


Thread Tools
Search this Thread
Quick Reply: fuel not getting to throttle body


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.