Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

Help!!! Blazer having trouble moving.

  #1  
Old 04-27-2011, 12:28 PM
New Member
Thread Starter
Join Date: Apr 2011
Posts: 9
TB2Blazer is on a distinguished road
Default Help!!! Blazer having trouble moving.

I am in desperate need of some input. I have an 85 K5 Blazer six inch suspension lift three inch body lift 40" TSL 350 motor with truck avenger carb and a th700R4 transmission. Now for the problem the truck has been sitting about a year and a half at my parents barn and has not been moved in a year and a half. Before I parked it a year and a half ago it ran great no engine trouble and no transmission trouble at all whatsoever it all ran smooth. Well I finally rebuild the carb after all that time sitting and change the oil and filter and put new air cleaner on it and start it up it runs great. I go to put it into drive and I hit the gas and it stalls like I have my foot on the break. Start it back up and rev a bit then try again it moves but its like i'm trying to push a house with it. The engine revs high and it moves forward but only if I'm really giving it some gas i let off the gas and it seems to want to stall but only when its in gear. So I try reverse seems to reverse ok but I can still tell something is not right it takes too much engine power to move it. I put it in 4 wheel drive and now it moves a little easier but still feel that over exertion in the motor and feels like i'm pushing a semi. I notice that the back right tire seems to be moving faster than the left sometimes and after driving it about 200 yards I noticed a smell that smelled like burning brakes. Question is do I need a new tranny or are my brakes bound up somehow over time? And yes I checked the emergency brake it was off.
 
  #2  
Old 04-27-2011, 04:57 PM
New Member
Thread Starter
Join Date: Apr 2011
Posts: 9
TB2Blazer is on a distinguished road
Default

Nevermind
 
  #3  
Old 04-27-2011, 05:00 PM
Starting Member
Join Date: Jul 2010
Location: Minnesota
Posts: 181
Z71_Guy is on a distinguished road
Default

what did you find?
 
  #4  
Old 04-28-2011, 06:44 AM
New Member
Thread Starter
Join Date: Apr 2011
Posts: 9
TB2Blazer is on a distinguished road
Default

I'm an idiot........low transmission fluid. Forgot to check it while the engine was running.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bat6180
Steering, Suspension & Drivetrain
3
11-14-2012 02:39 PM
Rando-s_R_and_C
Engine & Transmission
5
03-16-2012 09:05 PM
Tree liver2
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
2
09-30-2010 08:58 PM
lad446
Engine & Transmission
1
12-13-2007 09:30 PM
97Blaze
2nd Gen S-series (1995-2005) Tech
9
01-22-2006 06:33 PM


Thread Tools
Search this Thread
Quick Reply: Help!!! Blazer having trouble moving.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.