Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

Speedometer jumping

  #1  
Old 06-24-2009, 07:36 AM
Thread Starter
Join Date: Jun 2009
Location: Panama City Florida
Posts: 2
snakeboy38jm is on a distinguished road
Default Speedometer jumping

I am the proud owner of a 1993 full size chevy blazer 350V8, 4x4, auto My problem is the speedometer is jumping even in park i am doing 70+ MPH. I was told the VSS was the problem but the wrecking yard told me the cluster was the problem and i replaced it with the same results. Also the ABS light has been on for over a year.
Possible solutions
1) ECM ground wire?
2) VSS
3) ???
i had this problem 5 years ago and it corrected itself
also it happened after i jumped a Ford
 
  #2  
Old 06-24-2009, 06:33 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,792
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

I would definitely suspect the VSS before the gauge cluster.
 
  #3  
Old 06-25-2009, 09:03 AM
Thread Starter
Join Date: Jun 2009
Location: Panama City Florida
Posts: 2
snakeboy38jm is on a distinguished road
Default

I took off the wire to to the VSS sensor and it still had the problem. I have replaced the cluster to no avail. After having a transmission shop put it on the computer he told me the ECU must be bad, Guess what i just bought a new ECU and i still have the problem.
Lets check the score card
1) cluster $75
2) shop service call $80
3) new ECU $119
Knowing never to jump start a Ford Priceless
 
Attached Thumbnails Speedometer jumping-93-blazer.jpg  
  #4  
Old 06-25-2009, 06:00 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,792
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

ECU... Well, I would have suspected the DRAC (Digital Ratio Adapter Controller) module before the ECU as well. It is also possible that you have a wire grounding out somewhere under the truck or under the dash.
 
  #5  
Old 06-25-2009, 07:07 PM
Beginning Member
Join Date: Jun 2009
Location: Norris City,IL
Posts: 39
mahoney1988 is on a distinguished road
Default

do you have a aftermarket cd player....One time a guy in the town i live in put one in and his speedometer was jumping like that...it finally burnt his alternator up some how.. it does that every time he puts a cd player in it.. its the second time its happened.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
whoareyou4
2nd Gen S-series (1995-2005) Tech
2
08-14-2009 01:55 PM
BobTheBlazer
1st Gen S-series (1983-1994) Tech
4
07-16-2007 04:18 PM
breezy32784
2nd Gen S-series (1995-2005) Tech
1
06-29-2007 12:29 PM
soul_seeker77
Engine & Transmission
7
03-11-2007 04:41 PM
Hanr3
Off Roading
16
03-02-2007 11:32 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer jumping


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.