General Chat Chat about all things Blazer (and related vehicles). Off-topic stuff should be in the lounge, and all mechanical problems should be posted in the proper forum.

Battery?

  #1  
Old 12-27-2006, 08:44 PM
Junior Member
Thread Starter
Join Date: Sep 2006
Location: Lake Stevens ,Wa
Posts: 493
SDimeBlazerlady is an unknown quantity at this point
Default Battery?

Hi, this isnt a Blazer? But i just got my 87 Olds. 3.8...I drove it all over this morning and my last stop it started but stalled, When i tried starting it would turn over n battery died fairly fast..Its getting gas n its tried to turn over but im thinking it doesnt have enuff Battery power. Has new Alt. and battery wont take a jump...would it be best to say its got a bad battery? or something more evil wrong with it...car is parked near friends place so i cant run out n check stuff..Thanks
 
  #2  
Old 12-27-2006, 09:53 PM
Administrator
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,931
hillbillyinOhio has disabled reputation
Default RE: Battery?

is there a good connnection at the battery?? i would check and make sure that both terminals are getting good contact with the battery.
 
  #3  
Old 12-27-2006, 09:59 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,788
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: Battery?

If you can, pop out the battery and run down to your local Autozone or Advanced (if you have them). They'll test the battery for free. I have done this on numerous occasions to have them tell me it's fine so they aren't out just to sell you a new battery if you don't need it. The local Advanced Auto here has a VERY comprehensive tester that goes through a ton of tests.
 
  #4  
Old 12-28-2006, 04:36 AM
BF Veteran
Join Date: Jun 2006
Location: Vancouver. B.C. Canada
Posts: 3,429
Chevy Lover is a jewel in the roughChevy Lover is a jewel in the roughChevy Lover is a jewel in the rough
Default RE: Battery?

It's possible that the battery should have been replaced at the same time as the alternater, but like Kyle says, if you can get the battery out and have it tested, do that before you just go out and buy a new battery.
 
  #5  
Old 12-28-2006, 01:04 PM
BF Veteran
Join Date: Feb 2006
Location: Saskatoon, Canada
Posts: 3,333
blazinloud is on a distinguished road
Default RE: Battery?

happens to my mom and sister all the time, they phone me up, and i tell em to jiggle the battery cable, and voila. Check the posts for corrosion too.
 
  #6  
Old 12-28-2006, 01:14 PM
Junior Member
Thread Starter
Join Date: Sep 2006
Location: Lake Stevens ,Wa
Posts: 493
SDimeBlazerlady is an unknown quantity at this point
Default RE: Battery?

Well it has a good tight clean connection, i had been drivin the car all morning on errands. stopped at my friends for bout 20 mins went out.started up stalled fast, then when i tried to restart it seemed like it wouldnt catch...battery went dead after 3rd try...has new alternator. tried jumping it nothin tried starting a couple times,has gas,fuel pump is working i could smell it.ran a car with cable on it for 20 mins battery went dead soon as i turned it over..im thinking it has a bad cell.gotta wait til my brother comes over,car is bout 2 miles away!.....im kicking myself n letting the Blaze go
 
  #7  
Old 12-28-2006, 01:24 PM
BF Veteran
Join Date: Feb 2006
Location: Saskatoon, Canada
Posts: 3,333
blazinloud is on a distinguished road
Default RE: Battery?

yep, shoulda went the kidney route,lol
 
  #8  
Old 12-30-2006, 02:40 AM
Junior Member
Thread Starter
Join Date: Sep 2006
Location: Lake Stevens ,Wa
Posts: 493
SDimeBlazerlady is an unknown quantity at this point
Default RE: Battery?

Hi again, well battery n alt checked out ok at schucks..so we go hook everything up still no start! it turns over fine but doesnt catch...now what? bad spark? fuel pump done for? i think i need Chevy Lover to come fix my car lol i got $10 for gas lol any help would be greatful...im worried now bout car getting towed[&:]
 
  #9  
Old 12-30-2006, 03:24 AM
Junior Member
Join Date: Oct 2006
Location:
Posts: 457
MNHawk is an unknown quantity at this point
Default RE: Battery?

Just read back at the post on what the vehical is.

Look around the intake on the pass. side. If its wet with oil then your intake warped and blew out the gasket(they are known for this on the 3.1, 3.3, 3.8) Its an easy job to switch it out. But it would give the same issues that you are posting.

Good luck
 
  #10  
Old 12-30-2006, 03:43 AM
BF Veteran
Join Date: Jun 2006
Location: Vancouver. B.C. Canada
Posts: 3,429
Chevy Lover is a jewel in the roughChevy Lover is a jewel in the roughChevy Lover is a jewel in the rough
Default RE: Battery?

Just a guess....crank position sensor.....no spark
I'll be in Seattle at 3am Sunday
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
1998mom
Lighting & Electrical
5
07-25-2013 09:43 AM
TigaHotty85
Lighting & Electrical
16
06-17-2013 03:10 PM
chevyman93
Lighting & Electrical
4
12-17-2012 05:59 PM
tnw912
2nd Gen S-series (1995-2005) Tech
1
01-05-2010 05:27 PM
blazer1
2nd Gen S-series (1995-2005) Tech
6
07-25-2005 05:04 PM


Thread Tools
Search this Thread
Quick Reply: Battery?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.