General Chat Chat about all things Blazer (and related vehicles). Off-topic stuff should be in the lounge, and all mechanical problems should be posted in the proper forum.

Runs rough at idle

  #1  
Old 06-14-2010, 08:22 PM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 2
Fatherof5 is on a distinguished road
Default Buying my first blazer

Buying my first blazer. She's a 94 with 200k. When i looked at it there wasn't a battery in it. But once put in she started on like the third rotation after sitting all winter. But has a rough idle (really rough) until you reach about 30 mph. Then it stops. A friend of mine thinks its the fuel line coming because they're plastic at the manifold and crack over time and begin dumping too much fuel until you pick up your rpms enough to burn off all the fuel. Sounds plausible to me but i thought i'd ask the experts.
 

Last edited by Fatherof5; 06-17-2010 at 08:38 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
zakm0n
Engine & Transmission
12
01-10-2011 11:42 AM
Mr.T
2nd Gen S-series (1995-2005) Tech
9
07-30-2010 01:11 PM
demian5
2nd Gen S-series (1995-2005) Tech
2
03-07-2010 09:00 AM
cakt
Engine & Transmission
6
12-29-2008 04:01 PM
c10jm
Engine & Transmission
7
08-12-2008 05:34 PM


Thread Tools
Search this Thread
Quick Reply: Runs rough at idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.