General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

2000 4.3L 4-door 4x4 stuck in 4-Hi, help!

 
 
 
 
  #1  
Old 09-09-2006, 06:47 PM
Thread Starter
Join Date: Sep 2006
Posts: 5
Scubasteve2365 is an unknown quantity at this point
Default 2000 4.3L 4-door 4x4 stuck in 4-Hi, help!

Im a newbie to my blazer. Ive had it 2 months or so. I bought it from a guy I know, and it has been well taken care of. It has 74,000 miles on it. When I got it 2 months ago, I engaged 4WD just to test my understanding of how to engage it. It worked perfectly fine, and I never used it sense.

Today while driving on the highway, my service 4WD light came on. I pulled over checked some quick basic things that I could, and things seemed fine.

I arrived at my destination, and decided to shut the car off and turn it back on. At this time the "service 4WD light" was not on. I switched from 2-Hi to 4-Hi and it engaged fine. However it will not swtich back to 2-Hi. I push the button and nothing happens. No blinking lights, no nothing. Its as if Im not pushing the buttons at all.

Im an electrical engineer, so if I have to dig into testing continuity on the switches themselves to see if theyve gone bad, that will be no problem. I just figured Id ask some people familiar with these trucks if there are "common" problems in this area, and if there are any tricks in getting my truck back into 2-Hi. I dont wanna drive it 100 miles home on 4-Hi because I believe that to be bad (I know very little about 4WD, and this is my first 4WD vehicle).

What are my options for being out of town on the weekend?
 
  #2  
Old 09-09-2006, 06:50 PM
Thread Starter
Join Date: Sep 2006
Posts: 5
Scubasteve2365 is an unknown quantity at this point
Default RE: 2000 4.3L 4-door 4x4 stuck in 4-Hi, help!

wanted to add:

I have the Auto 4WD button if that matters.

And does the panel that holds the 4WD electronic buttons just pop out without having to take anymore of the dash apart?
 
  #3  
Old 09-11-2006, 12:29 AM
Junior Member
Join Date: Apr 2006
Location:
Posts: 467
RonJon is an unknown quantity at this point
Default RE: 2000 4.3L 4-door 4x4 stuck in 4-Hi, help!

Try checking the fuse (#15 instrument panel) are any of the indicator lamps lit on the buttons? They won't be if that fuse is blown. Yes with a bit of care the switch panel comes out of the dash, start at the top use a small screwdriver to start and use your fingernails so you don't scratch the dash. (or fingers and a holding screwdriver) The fuse powering the module itself is a 20A in the panel under the hood (marked ATC toward right edge) check there too.
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stingray74
General Chat
0
03-05-2015 08:27 PM
yardbird
2nd Gen S-series (1995-2005) Tech
0
05-18-2014 04:36 PM
larsnand
Steering, Suspension & Drivetrain
4
08-19-2013 11:11 PM
mr.vls
The Lounge
10
05-04-2013 03:45 AM
Havensk
2nd Gen S-series (1995-2005) Tech
6
07-25-2010 08:16 PM


Thread Tools
Search this Thread
Quick Reply: 2000 4.3L 4-door 4x4 stuck in 4-Hi, help!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.