General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

No Power-HELP!!!!!!

 
 
 
 
  #1  
Old 08-09-2006, 06:22 PM
Thread Starter
Join Date: Aug 2006
Posts: 1
jtlee425 is an unknown quantity at this point
Default No Power-HELP!!!!!!

I own a 2001 Chevy Blazer. I recently had my check engine light come on. I took it to the parts store to have them check it and the code came up "Air intake malfunction". They suggested that it might be the O2 sensor. I replaced the left one. Nothing changed. So I changed the right one. Still nothing. My truck just doesn't have any power.
Any idea what could be wrong?

Thanks for any info.
Janet
 
  #2  
Old 08-09-2006, 10:53 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,789
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: No Power-HELP!!!!!!

What was the code specifically? Looking down through the list, I don't see one that lists as you described. And if its an intake problem, I would not have changed the O2 sensors. That's $$$. I'd have changed the air filter, pcv valve, and cleaned the MAF sensor WAY before switching out the O2 sensors.
 
  #3  
Old 08-09-2006, 10:56 PM
Junior Member
Join Date: Jul 2006
Location:
Posts: 295
flowmasta is an unknown quantity at this point
Default RE: No Power-HELP!!!!!!

yea i agree...if u think its something to do with intake.... open the air box and let more air flow into the engine...if the light turns off then its an intake problem....if u had a friend with a blazer u could just swap mafs for a few to see if thats the cause..
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
flipzat
1st Gen S-series (1983-1994) Tech
1
12-02-2009 04:05 PM
fresno99
2nd Gen S-series (1995-2005) Tech
1
07-31-2009 08:12 PM
1991whiteoutblazer
Steering, Suspension & Drivetrain
4
01-08-2009 08:17 PM
nate2003456
1st Gen S-series (1983-1994) Tech
11
01-18-2007 01:10 AM
freeman
1st Gen S-series (1983-1994) Tech
2
08-23-2005 10:55 PM


Thread Tools
Search this Thread
Quick Reply: No Power-HELP!!!!!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.