Lighting & Electrical Post your lighting and chassis/engine electrical questions here. Any audio/video questions should be posted in the 'Audio/Video Electronics' section.

Fuel gauge, temp gauge, 4x4 lights

  #1  
Old 02-05-2012, 06:38 PM
Starting Member
Thread Starter
Join Date: Feb 2012
Posts: 1
JonZRDeuce is on a distinguished road
Default Fuel gauge, temp gauge, 4x4 lights

I'm puzzled. My 99 zr2's 4x4 lights on the selector buttons are out. low fuel light is on, gauge says empty. temp gauge down below 100, neither one will move. Initially, i thought someone syphoned all my fuel because i had a full tank . battery light stays on. any help would be appriciated. i tried to disconnect the battery, that didn't work. i'm afraid it's the ECU but i don't wanna spend the money if i don't have to. as i said, ANY help would be appriciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
grayman63
2nd Gen S-series (1995-2005) Tech
6
07-17-2013 01:56 PM
zakm0n
Engine & Transmission
5
01-09-2011 07:31 PM
Malachai
Engine & Transmission
1
03-27-2010 10:00 PM
mboehler
2nd Gen S-series (1995-2005) Tech
7
01-16-2009 07:16 AM
Mulisha
1st Gen S-series (1983-1994) Tech
5
03-24-2008 09:14 PM


Thread Tools
Search this Thread
Quick Reply: Fuel gauge, temp gauge, 4x4 lights


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.