Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

fuel gauge problem

  #1  
Old 04-27-2016, 10:02 PM
New Member
Thread Starter
Join Date: Apr 2016
Location: Florida
Posts: 3
branchbuster is on a distinguished road
Default fuel gauge problem

Ok new to the site and to forums in general. I am posting this here and posted in Lighting and Electrical too b/c I was not sure where the most appropriate place was...So here goes...
I have an 89 Jimmy 4x4 that has a faulty fuel gauge. It always reads empty regardless of how much gas is in the tank. I have been trying to resolve this issue for some time now and have at this point replaced the sending unit, fuel pump, and gas tank. I have also checked and cleaned every ground wire on the sending unit as well as the grounds from the battery to the engine and frame. After all this, the gauge still only reads empty. Here is the odd part, when I had the tank out and the sending unit connected outside of the tank, when I manually move the float arm assembly up and down the gauge works perfectly. I have done this twice now and everytime I put the sending unit back in the tank, the gauge does not work. Any suggestions of help with this will be much appreciated!!!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
grayman63
2nd Gen S-series (1995-2005) Tech
6
07-17-2013 01:56 PM
JonZRDeuce
Lighting & Electrical
0
02-05-2012 06:38 PM
hoppy26
Lighting & Electrical
0
01-26-2012 02:08 PM
Mulisha
1st Gen S-series (1983-1994) Tech
5
03-24-2008 09:14 PM


Thread Tools
Search this Thread
Quick Reply: fuel gauge problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.