General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Turn signals don't work!!!

 
 
 
 
  #1  
Old 11-14-2006, 12:10 AM
Administrator
Thread Starter
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,931
hillbillyinOhio has disabled reputation
Default Turn signals don't work!!!

Well, today I noticed that my turn signals don't work anymore. they just light up solid. My hazards still work fine. My guess it is the flasher relay, but where the heck is in on my truck???? If anyone has any other suggestions, I would appreciate it.
 
  #2  
Old 11-14-2006, 12:12 AM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,802
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: Turn signals don't work!!!

I do believe it's one of the ones behind the glovebox...
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gstxtt
Lighting & Electrical
0
12-05-2013 02:56 PM
SubbinBlazer
Lighting & Electrical
2
05-24-2013 12:56 PM
supermancs
2nd Gen S-series (1995-2005) Tech
13
03-19-2008 07:42 PM
The Franchise
Audio/Video Electronics
14
03-10-2007 10:54 PM
blazin97
2nd Gen S-series (1995-2005) Tech
3
02-22-2005 01:49 AM


Thread Tools
Search this Thread
Quick Reply: Turn signals don't work!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.