General Chat Chat about all things Blazer (and related vehicles). Off-topic stuff should be in the lounge, and all mechanical problems should be posted in the proper forum.

SORD Winch Plate... Mounting Holes wrong?

  #1  
Old 03-06-2019, 05:43 PM
Wheela's Avatar
Beginning Member
Thread Starter
Join Date: Jan 2013
Location: Palmetto Florida
Posts: 35
Wheela is on a distinguished road
Default SORD Winch Plate... Mounting Holes wrong?

Hello all, a couple weeks ago I ordered a Sky Off Road Design winch plate on 4wdfactory.com for all S10 applicable vehicles and today it finally came! I instantly took it to the garage to start lining up holes to make sure it would mount correctly(was going to powder coat it tomorrow). Sure enough I tried to line up the holes with the ones already in the frame and not a one lines up... The hole locations on the plate look just like the ones on the site, yet if you look at syngery's plate their hole locations are identical to the hole locations that are actually on the frame...(I should have just dropped the $70 more and gotten it...) Just wanted to see if anyone else's ever gotten this plate had the same issue or am i just crazy. Already sent an RMA request to send this back and to try and recoup some of the money I sank into it and just order the synergy plate. I've attached a picture comparing the plate i got and the frame holes, please excuse the horrible MS Paint editing, not the most tech savvy guy.

 

Last edited by Wheela; 03-07-2019 at 05:20 AM. Reason: Noticed something wrong
  #2  
Old 03-06-2019, 09:00 PM
blazen_red_4x4's Avatar
Super Member
Join Date: Apr 2014
Location: Lake City, Florida
Posts: 1,355
blazen_red_4x4 is on a distinguished road
Default

That's kinda crazy... The mounting holes on my 04 4x4 non ZR2 are more staggered than yours and mine lined up perfectly...

What's the details on your Blazer? Year and trim level and all?









 
  #3  
Old 03-07-2019, 03:16 AM
Wheela's Avatar
Beginning Member
Thread Starter
Join Date: Jan 2013
Location: Palmetto Florida
Posts: 35
Wheela is on a distinguished road
Default

Mines an '01 2dr ZR2 4x4

Yours looks so good Blazen, what hardware did you use to mount it?

(waiting on 4wdfactory response to my RMA, if they accept I'm sending it back and immediately ordering a synergy, if they refuse I'll just powder coat it and try to sell it)
 

Last edited by Wheela; 03-07-2019 at 05:24 AM.
  #4  
Old 03-07-2019, 06:10 AM
blazen_red_4x4's Avatar
Super Member
Join Date: Apr 2014
Location: Lake City, Florida
Posts: 1,355
blazen_red_4x4 is on a distinguished road
Default

Originally Posted by Wheela View Post
Mines an '01 2dr ZR2 4x4

Yours looks so good Blazen, what hardware did you use to mount it?

(waiting on 4wdfactory response to my RMA, if they accept I'm sending it back and immediately ordering a synergy, if they refuse I'll just powder coat it and try to sell it)
Only thing I can think of is it being a ZR2 thing, but I'm pretty sure the picture they have of it on their web site is on a ZR2? Still, weird...

Could always open the hole up a little?

I actually used the original tow hook mounting bolts and some nuts for the outer most holes and some new bolts for the inners that are also the skid plate mounting holes, and some new bolts and nuts for the mounts that go horizontal on the inside of the frame.

 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
newguy
General Chat
10
01-04-2014 05:26 AM
softail88
Engine & Transmission
2
09-15-2011 06:55 PM
Sturg
General Chat
2
02-01-2011 11:37 PM
Gary99
Off Roading
5
11-26-2010 03:01 PM


Thread Tools
Search this Thread
Quick Reply: SORD Winch Plate... Mounting Holes wrong?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.